Important Processing Notice - TLS 1.2

IMPORTANT PROCESSING NOTICE

The Payment Card Industry Security Standards council has determined that TLS 1.0 and 1.1 are no longer secure, due to previously identified security vulnerabilities. As of February 1, 2016, Sparrow will no longer allow connections to the following web applications from internet browsers that utilize the insecure TLS 1.0 and TLS 1.1 protocols:

  • secure.sparrowone.com
  • secure.5thdl.com
  • secure.mimsbilling.com
  • mypaymentmanager.com

Please review the current browsers or other applications that your organization uses to connect to the above Sparrow applications, and inform us immediately if you are using versions that do not support TLS 1.2.  TLS 1.2 will be the only allowed secure protocol, and the following Internet Browsers have TLS 1.2 support built in by default:

  • Google Chrome v 30+
  • Mozilla Firefox  v 31+
  • Microsoft IE v 11
  • Apple Safari v 7+

Please refer to this link for a full listing of browsers and TLS versions support.

http://en.wikipedia.org/wiki/Transport_Layer_Security

Please contact your IT Department to ensure browser compliance for the above listed web applications.  This matter is time sensitive and we appreciate your immediate attention.

 

Have more questions? Submit a request

Comments

Powered by Zendesk